DataHub GUI Ingestion Defaulting to Older CLI Version Despite Upgrade

Original Slack Thread

Hi Team, While running the ingestion from GUI by default it is taking the older version( not the newer version( . Every time when we upgrade we need to mention the CLI version while doing the configuration . Is it a known issue?

<@U04C7F09H43> It is known issue. <@U04N9PYJBEW> Do we have an issue for tracking ?

Thanks for replying. May i know when it will be resolved?

To be clear, is the issue here that ingestion from the GUI is taking an older version, or that there’s unexpected behavior when you manually set the CLI version and then perform a datahub upgrade? The former is intended: DataHub comes pre-configured to use the latest version of the DataHub CLI that is compatible with the server. Generally, we design our CLI versions to be backwards compatible, but that is not always the case, and we drop backwards compatibility for some features after they have been deprecated for some time.

<@U04N9PYJBEW> Thanks for replying. The issue is when I upgraded the datahub to latest version from CLI. And then I tried to ingest the data from GUI without mentioning the CLI version and it is taking the which is older version . Then I need to specify the latest version manually then only it is taking the latest version. My question is after upgrading by default it will take the latest version right but it is taking older version? Is that the issue ?

When you say “upgraded the datahub to latest version from CLI” do you mean you ran a pip install locally, or something else? If you’re talking about your local version, that is not tied to the version run by the GUI

I ran these commands to upgrade “python3 -m pip install --upgrade pip wheel setuptools
python3 -m pip install --upgrade acryl-datahub
datahub version” followed by " datahub docker quickstart"

And also i can see inside docker it is older version and outside docker it has latest version. Please Check the below image: