Discussion on resolving an error while running a Gradle command and generating a jarfile

Original Slack Thread

Hello all,
I am facing an issue when trying to run:
./gradlew quickstart -x yarnTest -x yarnLint

When I run this command, it gets all the way to the point where it is trying to run all of the containers but it gives me the error:
service "datahub-upgrade" didn't complete successfully: exit 1

To diagnose, I ran:
docker logs datahub-upgrade
and see the error:
Error: Unable to access jarfile /datahub/datahub-upgrade/bin/datahub-upgrade.jar

Has anyone ran into this before, if so, how do I fix?

Hey <@U04NXPFSFA7>! Thanks for joining us during office hours today & glad we were able to resolve this for ya :teamwork:

I’ve tried running the ./gradlew build command multiple times, but I am getting an error (I run a ./gradlew clean after each time):
error: error reading /home/&lt;username&gt;/datahub-vanilla-3/datahub/metadata-integration/java/datahub-client/build/libs/datahub-client-0.10.6-SNAPSHOT.jar; zip END header not found
Do you have any suggestions for how I should proceed?

You may have some temp files to clean up. Try ./gradlew clean then ./gradlew build

Hi David,
Thanks for the response! I have tried that, as well as cloning a clean version of the project, and a few other things as well (such as manually deleting that file).

Hi Ryan! After running that command, it still isn’t generating the jarfile my error is referring to (Error: Unable to access jarfile /datahub/datahub-upgrade/bin/datahub-upgrade.jar). Do you have any other ideas?

Can you check the build output directory for that file? Specifically: /datahub-upgrade/build/libs/