Inconsistencies in dbt Object Count and Assertion Search Issues

Original Slack Thread

hi all - wondering if anyone else has run into this issue as well? I’ve been noticing inconsistencies with the count of dbt objects that are appearing in our instance


Hey Nathan! That’s definitely unexpected - <@U04N9PYJBEW> might be able to help you figure out what’s going on!

<@U01GCJKA8P9> can you look into this? Seems more like a product issue. Should we try restoring indices?

im not sure if that is it

<@U04N9PYJBEW> does DBT produce things other than datasets?

if it produces containers, that may explain some of it. but doesn’t explain the total vs home page discrepancy.

It could definitely be stale cache on the home page, which would be solved by restarting datahub-gms pod… If it’s not that then it’s pssible that yes your indexing have become corrupted and need refreshed by following the restore indices guide :

Unfortunately not familiar with our dbt source. It can produce assertions for sure. cc <@U01GZEETMEZ>

hi all - we tried the reindexing which fixed the search discrepancy, but looks like there’s still a mismatch between the search and homepageattachmentattachment

The dbt source can produce other entities, like assertions, so that may explain the discrepancy

is it possible to get the urns for these assertions somehow? I can’t find them anywhere in the UI

I’m not sure if we have a way to search for assertions via the UI, <@U01GCJKA8P9> any ideas? If you just want to confirm they exist and have access to your database, you can try running:
SELECT DISTINCT urn FROM metadata_aspect_v2 WHERE urn LIKE 'urn:li:assertion%' AND metadata like '%urn:li:dataPlatform:dbt%';