Inconsistency with `sink.config.server` Configuration in DataHub Docker Environment

Original Slack Thread

Hello All,
I am using quickstart to explore DataHub. I notice a thing regarding sink.config.server . With datahub-dms running on docker as per|docs I should use below config:

  # source configs
  type: "datahub-rest"
    server: "<http://datahub-gms:8080>"```
I tried running my recipe to ingest metadata using cli it fails saying unable to connect to host  `datahub-gms` . But if I use `localhost` it works.
Moreover, if I run recipe with `sink.config.server` set to `localhost` from UI it fails. But from UI host `datahub-gms` works.
Why is this inconsistency?

Below is version I am using
```DataHub CLI version: 0.11.0
Python version: 3.11.4 (main, Jun 20 2023, 16:59:59) [Clang 14.0.3 (clang-1403.]```

<@U03MF8MU5P0> might be able to speak to this!

The datahub-gms hostname is only available within the docker compose environment. It helps the datahub containers to communicate internal to docker but not external. The recipe in the UI managed ingestion runs on a container, the actions container internal to docker. If you’d like to add a hostfile entry, you can add datahub-gms to your hosts file.