Troubleshooting Datahub Deployment with Cloud SQL Postgres and Schema Configuration

Original Slack Thread

Hi, we’ve deployed Datahub w Cloud SQL Postgres (connected using cloud proxy). We want to set the DB schema, but we are having trouble doing this. We’ve tried to add search_path=XXX, currentSchema=XXX, etc to the end of the jdbc connection url, but its still not switching away from schema=public

Hey there! :wave: Make sure your message includes the following information if relevant, so we can help more effectively!

  1. Which DataHub version are you using? (e.g. 0.12.0)
  2. Please post any relevant error logs on the thread!

The jdbc url is pass through to the driver. There is no hardcoding of the public schema in datahub. I’d check the documentation for the cloud proxy to see if it is restricting or modifying the jdbc url in any way. I would also try using some tool like dbeaver ( to troubleshoot the jdbc url.

Yes, its was some restriction we had with our DB. We ended up just changing the default schema manually.