Troubleshooting 'datahub docker quickstart' CLI ignoring environment variables

Original Slack Thread

Hey folks :wave:,

Could anyone help me figuring out why datahub docker quickstart CLI ignores env variables? I’m just trying to set DATAHUB_VERSION both in my current session and in .zshrc, but it has no effect. What am I doing wrong there?

datahub docker quickstart -f docker-compose.quickstart.yml```
Compose file contains just a single change (attaching extra volume to `datahub-gms`), otherwise unchanged.

<@U04UKA5L5LK> Could you help here? thanks!

Hey <@U05NDLFDWPK>, I think this is the correct way to set the version:
DATAHUB_VERSION=v0.8.30 datahub docker quickstart
Can you try including the v?

<@U04UKA5L5LK>, thanks for suggestion (and actually I included v, just forgot to add it in example), but it still doesn’t work for me (even if I’m not providing my own compose file). I also tried .env file with no luck.

DATAHUB_VERSION=v0.10.5 datahub docker quickstart

CONTAINER ID   IMAGE                                   COMMAND                  CREATED         STATUS                             PORTS                                        NAMES
aa94511f01d2   linkedin/datahub-frontend-react:head    "/bin/sh -c ./start.…"   4 minutes ago   Up 20 seconds (health: starting);9002/tcp                       datahub-frontend-react
f8314f3fae91   linkedin/datahub-gms:head               "/bin/sh -c /datahub…"   4 minutes ago   Up 37 seconds (healthy)  ;8080/tcp                       datahub-gms

What is the error you get with that command? That one works for me!

There are no errors, everything’s fine. It’s just that env vars are ignored (still head and not v0.10.5 is being deployed).

Oh! I see. Let me see. To unblock you, do you want to check out the repo at that version?

Nothing blocks my work, since I’m customizing compose file - I can hardcode the version I need anyway. I’m just curious, why env var is ignored there.

I see. Actually, the same thing is happening to me. Let me look into it and get back to you!

If you’re not blocked, I will take some time to look into it if that’s okay!

I’m on a latest CLI version on M2 Mac:

DataHub CLI version:
Python version: 3.10.12 (main, Aug  4 2023, 11:27:01) [Clang 14.0.3 (clang-1403.]```

Thanks, same as me, so hopefully I can figure it out!

Hey <@U05NDLFDWPK>, here’s what I found: there is a command line flag that will allow this:

  Start an instance of DataHub locally using docker-compose.

  This command will automatically download the latest docker-compose configuration from GitHub, pull the latest
  images, and bring up the DataHub system. There are options to override the docker-compose config file, build the
  containers locally, and dump logs to the console or to a file if something goes wrong.

  --version TEXT                  Datahub version to be deployed. If not set, deploy using the defaults from the
                                  quickstart compose. Use 'stable' to start the latest stable version.```

Try using that flag and see if it gives the behavior you want!