Troubleshooting Docker Quickstart Failure with Ingest and Postgres

Original Slack Thread

Hey guys! I’m trying quickstart with docker and I want to create an ingest with postgres. When I run it, it fails and returns with a failure message:
“Ignored the following versions that require a different python version:”
“ERROR: Could not find a version that satisfies the requirement acryl-datahub[datahub-kafka,datahub-rest,postgres]”

I’m using the versions:
composefile_git_ref: master
docker_tag: head
composefile_git_ref: master
docker_tag: head
composefile_git_ref: v0.10.5
docker_tag: v0.10.5
composefile_git_ref: v0.9.6.1
docker_tag: v0.9.6.1

<@UV5UEC3LN> might help you

cc: <@UV14447EU>

<@U05BWULPDUY> Can you try to install dependencies one for each module?
This looks weird:

Well, the solution worked, but I had to do it in the datahub-actions container and in the venv that is created for the ingestion. It seems to me that this container’s datahub packages are different from the others, but as I still don’t have knowledge of the whole tool, I’ll leave it on the way so I can try it out! Thanks, Tamas!