Managing CLI Version Compatibility in Datahub Upgrade to 10.5

Original Slack Thread

Hi, Yesterday we upgraded our Datahub to 10.5 and Presto ingest failed with this error:

Traceback (most recent call last):
  File "/usr/local/lib/python3.10/site-packages/datahub/", line 175, in main
    sys.exit(datahub(standalone_mode=False, **kwargs))```
Please help. Full log in a file attached

Update: I've tried running ingest with previos CLI version (0.10.4) and it worked.
So looks like the problem is with CLI 10.5?![attachment](

The cli version is quite old -> cli_version": "
based on the logs.

<@UV14447EU> hmm, isn’t CLI version supposed to be updated along with release update automatically?

If you run your ingestion from the UI then it should except if you pinned your client in your ingestion ->

<@UV14447EU> I run ingestions from UI, yes. The CLI versions weren’t pinned when errors occured. So our Datahub was just upgraded to 10.5, but it had CLI for ingests for some reason.
Is it a bug on Datahubs side, or shoud we have set it somewhere while upgrading?
We are deployed via Kubernetes and helm charts

which version of datahub-action do you have in your helm chart ->

<@U03LYB2ESJ0> sorry, my previous answer was not correct as this is the config property in helm, which controls the default cli version of managed ingestion ->

<@UV14447EU> defaultCliVersion: ""

then if it is not pinned it should use the defaultCliVersion

Well it didn’t happen like that:woman-shrugging:
Something in my head rings a bell that it’s not the first time such thing happened among Datahub users. Maybe it’s worth checking on your side, as smth that looks like a bug?

well, I’m not super familiar with the helm side but I can ask around internally if somebody has seen an issue like this

Nice, thank you!

A few things to check:
• In GMS (or MAE Consumer in standalone mode) the environment variable UI_INGESTION_DEFAULT_CLI_VERSION should show the correct version in the deployment, can you double check this?
• When does your actions pod show it was last restarted? Did it restart with the rest of your deployments with the update?
• Query your ingestion sources and see what the input argument for the CLI Version was using this query:

  listIngestionSources(input: $input) {
    ingestionSources {
      executions(start: 0, count: 1) {
        executionRequests {
          input {
            arguments {
          result {

"input": {}
This should give the CLI version in the `value` field of arguments, the other fields are just included for identification purposes