Resolving caching issue with removed platform in Datahub after deleting Oracle platform using command line

Original Slack Thread

I have a problem after trying to remove a platform. I removed the Oracle platform via command line.

datahub delete --env prod --platform oracle --hard
datahub delete --env prod --platform oracle --hard --entity-type container

But the Datahub interface still shows the platform and number of objects.
If I go to Datasets > prod it still appears and when I select a schema it doesn’t show any datasets.

Interestingly, if we try to explore and search the platform, it doesn’t show any objects, but it also shows the filters on the left of the platform and the number of objects.

I tried some solutions like reindex to restore but it didn’t work.

Do you guys have any suggestions on what to do?


It is most probably a cache issue, restarting GMS might help

I already tried this, I even removed the entire application and installed it again.
Even when re-indexing it after reinstallation, it continues…

I’m thinking about deleting the PVC from Elastic and recreating it again

Facing the same issue, were you able to fix this?

<@U05BWULPDUY> Were you able to fix this?

Hi <@U050CKCMB55>!

So, I resolved a situation, yes!
I erased the base of the elastic (pvc from k8s) and created it again.

After I ran the reindex and it worked

Sorry for the delay :x