Airflow Integration Problem: Pydantic Conflict Resolution

Original Slack Thread

airflow integration problem

    apache-airflow 2.7.3 depends on pydantic>=1.10.0
    acryl-datahub-airflow-plugin depends on pydantic>=1.5.1
    apache-airflow[kerberos,ldap,statsd] 2.7.3 depends on pydantic>=1.10.0
    acryl-datahub depends on pydantic!=1.10.3, <2 and >=1.5.1
    The user requested (constraint) pydantic==2.4.2
To fix this you could try to:
1. loosen the range of package versions you've specified
2. remove package versions to allow pip attempt to solve the dependency conflict
ERROR: ResolutionImpossible: for help visit <>```

Hey there! :wave: Make sure your message includes the following information if relevant, so we can help more effectively!

  1. Which DataHub version are you using? (e.g. 0.12.0)
  2. Please post any relevant error logs on the thread!

yeah, unfortunately, our plugin doesn’t work with the latest Airflow due to the pydantic bump in Airflow.
We are working on bumping Pydantic on our side as well but it needs more time