Integrating Kubernetes Deployment with LDAP via jaas Configuration and DataHub User Management Issue

Original Slack Thread

Hello everyone! We managed to integrate our local Kubernetes deployment with our LDAP via jaas configuration. Here is how it looks.

WHZ-Authentication { sufficient

The problem we have now, is that the users are not saved in Datahub and we cannot assigned them to groups or give them permissions, etc. For some reason they are not saved in datahub. Note that we kept the datahub user as it has admin rights.

Does anyone encountered this? We are on v.0.11.0

Hey there! :wave: Make sure your message includes the following information if relevant, so we can help more effectively!

  1. Which DataHub version are you using? (e.g. 0.12.0)
  2. Please post any relevant error logs on the thread!

Hi <@U01T9TUS3NH> , I faced this recently and solved by ingesting users from the LDAP server using the LDAP source.

All right, I will give that a go.

Ok, that worked! Thanks a lot.

I had to install open ldap dev tools on my RHL client machine.