Troubleshooting installation issues for DataHub CLI in docker container

Original Slack Thread


Trying to install datahub CLI in docker container FROM python:3.9.16 but I run into issues:

Hey there! :wave: Make sure your message includes the following information if relevant, so we can help more effectively!

  1. Which DataHub version are you using? (e.g. 0.12.0)
  2. Please post any relevant error logs on the thread!

None of datahub version nor python3 -m datahub version works as you see

I tried from this docker image, but also in my local but I run into the same issues

Am I missing a step ?

We have run into the same error and couldnt get it resolved, any additional steps to resolve this error would be appreciated!

this issue is due to Python libraries being compatible, could you try to use the newer version of Python like Python 3.11
run. After the new version python install in a separate Python virtual environments

python3 -m pip install --upgrade acryl-datahub
datahub version```