Troubleshooting issues with the Datahub CLI and local docker setup

Original Slack Thread

morning all, I ran into a problem with the <|quickstart instructions>, went off to github to see if it was a common issue, and saw that this slack existed. is this the right place to ask for help? or maybe I should head over to <#C029A3M079U|troubleshoot> ? (I can provide more details of the issue, but I want to find the right place first!)

I have a similar problem to <Issues · datahub-project/datahub · GitHub issue raised two weeks ago>, which I see was fixed - a python error when I run datahub version (or any other datahub cli command, just after I’ve run <DataHub Quickstart Guide | DataHub first few poetry commands in the “Install the Datahub CLI” section>

ah, on further digging I think maybe that issue is fixed but not released?

now I realised this, I’ve resolved it by manually downgrading pydantic to <2.0 (pip install "pydantic&lt;2.0" ) - in case it helps the next person to stumble across this :slightly_smiling_face:

I’m having some other issues with the quickstart process, so I’m still interested in whether <#C029A3M079U|troubleshoot> or here is the right place for questions.

Hey Kyle- this is the right place for help.

What are your other issues?

the current problem I have I think is related to my local docker setup - though I think the error message could be misleading

I looked at the source, and I believe it’s this method that’s failing:

and the message returned to the user in this case is:
> Docker doesn’t seem to be running. Did you start it?

but docker is certainly running (I’m on ubuntu and various docker commands do respond to me) - but docker.from_env() in the python SDK throws an error. so this error message kind of obscures other docker issues?

I’ve been pulled away to something else, but when I return to it I’ll investigate how my users / docker setup is, because I have it running without sudo (as recommended in the docs) but I suspect my setup is non-standard.